Back to overview
Downtime
Cloudflare DNS 521
Apr 10, 2026 at 4:22am UTC
Affected services
Wordpress
Resolved
Apr 14, 2026 at 4:47pm UTC
Hosting provider resolved further issues with Cloudflare connection
Affected services
Updated
Apr 10, 2026 at 7:05pm UTC
Hosting provider resolved issue
Affected services
Updated
Apr 10, 2026 at 6:16pm UTC
Identified, hosting provider working to fix issue
Affected services
Updated
Apr 10, 2026 at 6:26am UTC
Cloudflare proxy grey-clouded to maintain access until the origin server issue can be resolved
Affected services
Created
Apr 10, 2026 at 4:22am UTC
Cloudflare to origin server DNS issues are causing limited or no access to the site
Affected services